Add Comment | Related Links | TrackBack
Related Content

Western Digital Elements External Hard Drive Disassembly

Hmm, maybe the SATA USB adapter broke when you opened up the drive. I don't have a problem connecting a 640 MB Hitachi or a 1TB Samsung drive to the adapter and both work without any issues.

Thank you for the details on how to open the box.

Fri, 28 May 2010 13:33:12 +0000

Thanks for the tip, Martin. I'll have to try again then.

Chieh Cheng
Sat, 29 May 2010 07:06:30 +0000

I tried to put a WD10EADS in the case and it doesn't work for me. THe only difference between the drive it came with and this one is the size. Am I'm not doing something right?

Sun, 06 Jun 2010 04:36:28 +0000

I want to add that the WD10EADS works fine when I connect it directly to the computer as a regualr hard drive. Also the WD20EADS works fine when connected directly to the computer and when I reconnected it to the USB/SATA adapter so I know th adapter is fine. Since the WD20EADS came preformatted is there a certain way it was formatted to work in the Elements case?

Mon, 07 Jun 2010 08:42:15 +0000

I had the same problem that the USB adapter won't work with any other drive than the one that came with the enclosure. I think WD programmed the USB adapter that way. That's too bad.

Chieh Cheng
Mon, 07 Jun 2010 16:33:24 +0000

Thanks for the quick reply Chieh. I don't know how Martin did it. Guess I'll have to buy a HD case for my WD10EADS. Also thanks for the great pictures on how to open it and showing what was inside. I didn't want to deal with the advance formatting of WD20EARS so this was a great way to get a WD20EADS.

Tue, 08 Jun 2010 07:01:01 +0000

Just purchased WD Elements 2TB from Mircocenter.Priced at $169.00 I paid $129.00 due to price matching with Newegg.Sales clerk didn't know RPM and cache.We checked web and couldn't find anything.I did a Google search at home and ran across your website.Thanks for the FYI...7200RPM - SATA - 32mb cache.I wonder why Western Digital is so secretive about disclosing information on there web site?

Tue, 22 Jun 2010 04:21:59 +0000

My only guess is that they don't want you to buy an external version just to pull out the drive . . .

Chieh Cheng
Fri, 25 Jun 2010 15:30:12 +0000

I just got one of these from Newegg (109.99) and the instructions were superb. I was able to attach the usb to sata connector to multiple hard drives and it was fine. Just FYI

Chad Robbins
Thu, 05 Aug 2010 16:48:53 +0000

Thanks for the update, Chad. From your info, I'm guessing that there are different versions of the USB/SATA adapter for these external enclosures.

Chieh Cheng
Thu, 05 Aug 2010 17:15:12 +0000

I was able to swap out the original hard drive with a Hitachi 1TB drive and it works fine just like any other external enclosure. You should change your article because it almost discouraged me trying out the swap.

Buttocks Maven
Wed, 01 Sep 2010 17:28:14 +0000

bought this enclosure on ebay (without hdd) and was able to attach WD 1TB without any problem. It only took me 20 minutes to figure out how to open it. I'd rather have like 4 screws on the bottom or so.

my guess would be faulty SATA to USB adapter etc.

jozko kunyk
Wed, 13 Oct 2010 11:43:49 +0000

I picked up two of the 2TB units from Target, and they both had WD2001FASS drives in them. They're the WD Black series - 7200RPM, 64MB cache, SATA 300. Much better than the green series that came in the one in the article..

$69 per unit, and the WD2001FASS drive currently sells for $169 near my place :D

Sun, 28 Nov 2010 06:09:59 +0000

I tried my Barracuda 1.5 GB drive in the enclosure again. It still fails. When this drive is connected, the LED on the back flashes on and off. The drive also doesn't spin up.

Chieh Cheng
Tue, 30 Nov 2010 02:17:44 +0000

The USB adapter board that I have in my possession has the following designations:


When you report whether your board works with other hard drives, please provide the designations on your board for comparison. Thanks.

Chieh Cheng
Tue, 30 Nov 2010 02:27:26 +0000

Same Here, My Oasis adapter is the same model. The drive works fine over internal SATA but once put into the case, it is found in disk management but doesn't show up in My Computer. I have tried different applications to format it inside of the USB case, but no luck. It says access denied!

Real shame, because I really like the way the enclosure is.

Tue, 30 Nov 2010 17:25:40 +0000

I also bought one of these at Target on Black Friday and found a WD2001FASS Black Edition drive inside. I hooked up my Seagate ST3500320AS to the USB-SATA adapter and it worked fine, however I also hooked up my WD1500ADFD Raptor and it gives me the drive is write protected error in Windows 7's disk management when I try to initialize it. I haven't tried my Maxtor 7L300S0 yet.
Board details:
4060-705078-001 REV.A

Fri, 03 Dec 2010 21:29:21 +0000

I opened up a 2TB drive i purchased from target during "Black Friday" for $69, and i was very happy to see a WD Caviar Black inside. And the adapter works with at least 2 of my other sata drives i have out.


Thu, 09 Dec 2010 01:58:14 +0000

I have a 1TB model with an EADS drive and was able to swap it out with a Seagate LP 1TB drive.
I took the drive out to put it in my Acer Easystore WHS.
The adapter is marked with OASIS UULC3.5 4050-705062-000 REVP1 and is only half the width and attaches to the drive with only one screw.

Thu, 09 Dec 2010 23:42:03 +0000

Thanks for the guide Chieh Cheng. I had no luck swapping with a 1TB Samsing HD103UJ. The drive is recognised in Win 7 storage device manager however it is reported as requiring initialization. Any attempt to initialize does not work - write protected error message. The Sata to USB board inside is OASIS DESKTOP 1607P, REV.B 4060-705078-001. The original drive inside the enclosure was a WDC WD20EARS-00MVWB0. Using SIW - System Information for Windows (free version from ) I was able to tell the drive before opening it up.

Mon, 27 Dec 2010 15:25:08 +0000

Does anyone know where I can purchase the

Seperately? I have a damaged card and need to replace it. I have proprietary information on that drive and do not wish to send it RMA to Western Digital.


Tue, 04 Jan 2011 15:38:53 +0000

I just bought a new WD20EARS, hoping to use it in a 500GB enclosure I have. In a forum, opinions varied concerning my likely success, but one poster said he could sell me an empty WD Essentials 2TB enclosure cheap, and I soon decided (before my HD arrived) that this was a good idea. The enclosure and HD arrived yesterday and I figured out how to install the drive this morning and it's currently 63% formatted by one of my XP laptops. So, yes, it's possible to install another HD in one of these. I think probably any WD 2TB drive would work, however mine is advanced formet. I configured XP to use 4096kb allocation size (offered were DEFAULT, 512, 1024, 2048, 4096, 8192, 16k, 32k). I plan to run WD Align once formatting is complete and run tests on the drive to ensure it's fully functional.

Dan Musicant
Fri, 07 Jan 2011 01:11:27 +0000

I was able to install a 500GB Hitachi into the enclosure without a problem, maybe you guys should make sure your drives are formatted correctly before connecting them to the adapter?...

Wed, 23 Feb 2011 04:55:27 +0000

Thanks for sharing how to dismantle the case.

The Oasis desktop 1607P REV A 4060-705078-001 works with a WD1600YS

Richard van den Berg
Sat, 05 Mar 2011 20:57:41 +0000

Good article. You can find videos on youtube to dismantle if you need a visual disassembly.

I have a

...and tried it with many different drives and found it works fine with some and not with other drives.

Looks like WD has messed around with the initialization of the SATA to USB adapter when powering up the drives.

Some drives would spin up, others would not.

Operational drives would work fine and disk managment would handle them no worries.

Tue, 15 Mar 2011 20:48:47 +0000

Thanks for your input, Bob. That really shed light on why all the boards have the same designation, but some drive works and some drives don't. I guess all the drives I tried with it do not work and made me think that this board won't work with any other drives. With your insight, I think I'll keep trying new drive as I get them and keep these boards as gadgets in my drawer.

Chieh Cheng
Tue, 15 Mar 2011 23:42:05 +0000

First of all, thanks for all the info.

I recently bought one of these, which came with a WD20EARS.
Mine come with
I've tried the board with a Seagate Barracuda 1.5T, and the drive didn't even spin.
I also tried with a WD2500, and it worked fine.

Is the ROM made to work only with WD HDs? donno...

Thu, 31 Mar 2011 14:27:54 +0000

I just bought one, it also came with Oasis 1607P controller REV B 4060-705078-001 , and a WD20EARS.
Didn't try any other drives.

Sat, 30 Apr 2011 18:06:49 +0000

Hello guys, i have a WD ELements with 1 TB and replaced the 1TB disk with a 500 GB one. It worked fine, and even my 160GB disk is recognized by the controller.

My model is a "Oasis Desktop 1607P" and the Metal clip reads:

"4056-705123-000 REV-AA"

I hope this helps you!

Greets from Germany, Michael

Thu, 14 Jul 2011 08:40:55 +0000

I tried with a Seagate barracuda 500GB
The white led flashes but the drive doesn't work.


Tue, 26 Jul 2011 15:55:09 +0000

Hello, can someone with the OASiS DESKTOP 1607P REV B board tell me what is the model number of the 8-Pin IC located just behind the DC Jack?

The part number designation is U2.


Wed, 03 Aug 2011 05:58:00 +0000

It's too small for me to read. So I shot a photo of it with my camcorder and enlarged it on my computer. It helped slightly, but I still can't make out what it says. I've attached the image below. Maybe you can make out what it says.

Attached Image:

U2 IC.png

Chieh Cheng
Sun, 07 Aug 2011 01:03:21 +0000

My WD1.5TB external drive (with WD1501FASS Caviar Black) has Oasis Desktop 1607P USB/SATA board showing RevB 4060-705078-001.

The U2 chip is labeled -

*043B * This character (before 043B) is unreadable or is simply a "dot".

Used old-skool magnifying glass! :-)

Mark Scholmann
Tue, 16 Aug 2011 10:58:06 +0000

I have recently bought a 1.5To WD Hard drive WDBAAU0015HBK-EESN.
I'm using Linux Ubuntu and want to format HDD in ext3 filesystem.
Originally, it was NTFS formatted and well recognized.
As soon as I have formatted, no recognition, with the USB adapter (OASIS Desktop 1607P Rev B)
The hdd alone, works well connected directly to SATA port of mother board.
I tried another HDD (Toshiba 250Go SATA 2.5") formatted in FAT32 / NTFS and it works !!

I think this USB2SATA adapter is not fully compatible and all functions are not implemented.

for the U2 Chip : mine is MSC 7101IDM 047G
U3 : APM4532 RN13U
U4 : Winbond 25X10BVNIG 1110
U1 : INITIO INIC-1607P C11 E46280111 1108

Tue, 30 Aug 2011 08:42:07 +0000

The U2 chip looks to be a standard I2C EPROM chip. It might contain information on the drives it's supposed to connect, and that would mean the adapter is simply hard-coded to fail in case the drive's ID does not match the ID string programmed in the EPROM.

If someone could read out the EPROM we may be able to find out something more. I wouldn't be surprised if there was a string in there that reads "WD20EARS" with some kind of revision number. Which means the enclosure should be straightforward to hack to other drives just by reprogramming the EPROM to match the drive ID string.

Tue, 30 Aug 2011 11:58:38 +0000

U1: INIC-1607P - SATA to USB Bridge Controller IC -
U2: MSC 7101IDM - 2A High Voltage Synchronous Buck Converter -
U3: APM4532 - Dual Enhancement Mode MOSFET - . . .

U4 is used as ROM for U1 and stores firmware for whole OASIS DESKTOP 1607P device. So probably here we have our problem. U4 is flash so it should be easy to reprogram it with some other firmware.

Sun, 04 Sep 2011 20:01:39 +0000

I inadvertently plugged my laptop power supply into my external drive and now the white light doesn't light up & the drive doesn't work. Is there any way I can use the above information to retrieve my data?
Thanks for any help. David

David Davis
Mon, 05 Sep 2011 13:41:01 +0000

You can take out disk from that black box and use it as normal SATA HDD in Your computer. Or put it in another "SATA to USB" enclosure.

Mon, 05 Sep 2011 15:46:09 +0000

Someone much more intelligent than I am may be able to figure out my problem regarding the Oasis Desktop 1607P controller. I was helping a friend remove the virtual CD capabilities and hidden partition off his Toshiba and when I ran the removal tool (no longer on their site thankfully) , it affected my WD 3TB Elements drive. It wont even show up in the drive management connected to the sata to usb controller. So I popped it out and hooked it up and my data was gone. I stupidly ran testdisk to recover but it doesnt seem to support GPT partitions so I believe it screwed it up even more. It looks like it now had a MBR and is split into two partitions. I converted it back to GPT but I fear this screwed it up even more. I tried every data recovery prog I could find and they all found nothing but garbage. My question is, can I repair the firmware on this oasis desktop 1607p controller so I can hook the drive up via USB again?

Thanks to anyone who may have an answer/suggestion!

Great site.


Fri, 16 Sep 2011 22:27:15 +0000

One of the things - if not the only one - which seems to keep drives from working in these enclosures is that the SATA/USB converter seems to do funny things with the drive geometry. Take a drive from an enclosure and attach it to SATA and it will work. Take a drive which has been partitioned through SATA and put it in the enclosure and...

EXT4-fs (sdb1): bad geometry: block count 244190000 exceeds size of device (244189944 blocks)

Hmmm, what happened? The drive is unchanged, attach it through SATA and it works as normal. Looking at the partition table when connected through USB shows the following:

Disk /dev/sdb: 1000.2 GB, 1000202043392 bytes
255 heads, 63 sectors/track, 121600 cylinders, total 1953519616 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sdb1 63 1953520064 976760001 83 Linux

Indeed... a drive with 'total 1953519616 sectors' will not be able to hold a partition which ends at '1953520064'. When connected through SATA the same drive type shows up as:

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xDEADBEEF

SATA: 255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
USB: 255 heads, 63 sectors/track, 121600 cylinders, total 1953519616 sectors

Someone stole a cylinder! Either the Oasis controller has an off-by-1 error somewhere, or it intentionally misreports the geometry for reasons unknown. Whatever the cause of this discrepancy, it means that partitions created on a 'native' SATA controller might end up being to large to work through the SATA/USB controller.

Given that I have enough backups of the data on the drive I decided to experiment a bit:

# resize2fs -f -p /dev/sdb1 244189944
resize2fs 1.42-WIP (25-Sep-2011)
Resizing the filesystem on /dev/sdb1 to 244189944 (4k) blocks.
The filesystem on /dev/sdb1 is now 244189944 blocks long.

# e2fsck -f /dev/sdb1
e2fsck 1.42-WIP (25-Sep-2011)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
media_01: 633868/61054976 files (2.9% non-contiguous), 184622721/244189944 blocks

I then used fdisk to resize the partition (by first deleting it, setting the dos compatibility flag to allow partitions to start on sector 63, and finally creating a partition starting at sector 63 covering the whole disk). The end result is that the drive is now running in the enclosure with the original data on it.

TL,DR: the SATA/USB controller reports the drive geometry incorrectly - the number of cylinders is reduced by 1 leading to a reduction in size by (heads * sectors/track * 512) bytes. To get file systems covering the whole drive to work through it you'll have to reduce their size to get them to fit.

Frank de Lange
Thu, 06 Oct 2011 08:11:29 +0000

Thanks for this detailed insight, Frank. It'll come in handy when I mess with these USB/SATA adapters again.

Chieh Cheng
Thu, 06 Oct 2011 19:52:52 +0000

OASiS DESKTOP 1607P with "Rev B" on the backside of PCB
controller: INITIO INIC-1607P C11 E39957111 1031
works fine with Seagate ST3120811AS

Edgar Ka
Thu, 20 Oct 2011 13:38:42 +0000

i have a western digital desktop external hdd 1.5tb sata/32 mb cache any ways i have the same problem. my usb adapter plug on the board itself is about to fall off and not even had it bit almost 2 months does any one know where i could get a direct match of the adapter board that plugs to the sata plugs on the hdd and to the 2.0 usb and 12v 1.5amp power supplied plugs?? any info. would help


Tue, 01 Nov 2011 21:33:04 +0000

I recently bought two Western Digital Elements 2T external hard drives in order to upgrade the 500G drives in my computer. The idea was to use the 500G's as external drives afterward.

Getting the 2T's to work in the computer was a snap but not so the 500G's in the cases. They didn't spin up and the leds flashed.

Google didn't help much but it did make me realize I am not the only one with this problem. That's why I'm sharing the solution I stumbled upon through trial and error:

Basically what I did was to put the HDD into another, non Oasis based, external enclosure. The computer picked it up as expected and I was able to do a low level format. I then took it out of the enclosure and reconnected it to the computer via the Oasis adapter. This time the drive registered and I was able to create a partition and NTFS format it.
After that the drive worked fine.

The enclosure I used for the low level format is an earlier version of WD elements (the ones with the anodized aluminium case and rubber ends).
For the low level format I used HDDGURU's free HDD Low Level Format Tool v4.25 (format took around 6 hours to complete)
For creating the partition and formatting it I used Partition Genius off a Wondershare LiveBoot 2012 disk.

The software and the enclosure I used was just what happened to be around and I have no way of telling how critical it is for the fix to work.

The Oasis adapters are both Desktop 1607P rev B
and the HDD are both Seagate ST3500320AS

Hope that is of use to someone.

Karel van der Walt
Tue, 24 Jan 2012 13:35:02 +0300

Thanks Karel for this glimpse of your insight. Maybe there is light at the end of the tunnel after all. I wonder if it has anything to do with a the earlier version of WD Element adapter you used. I will attempt to duplicate this process using a non-WD adapter when I get a chance.

Chieh Cheng
Tue, 24 Jan 2012 21:24:14 +0300

thanks karel, hddguru's tool worked just fine for me; btw i was using a non Western Digital Adapter for the low level format

Sun, 12 Feb 2012 23:24:16 +0300

I read some of u opend the case.
can somebody tell me what the value of R2 is.
It got fried in the case of a friend of mine he asked me if I could repair it
and it seems like that just the Resistor was blowen apart.
I thougt it might be worth a try.
So if somebody could tell me the vallue it would be great.

Fri, 02 Mar 2012 22:39:19 +0300

Sorry for my doublepost.
But I named the false Resistor.
It is R63, right of the Osszillator.

Fri, 02 Mar 2012 22:53:25 +0300

R63 on the Oasis Desktop 1607P is 4.7 Ω (= 4,7Ω).

Attached Image:


Wed, 28 Mar 2012 20:13:10 +0400

took a while for me to remember :-D
Thanks, will try it tomorrow!

Wed, 02 May 2012 22:34:17 +0400

My 2 TB Seagate harddisks don't work with the Oasis Desktop 1607P. The led is flashing and the drive is not spinning.

Sun, 06 May 2012 04:58:45 +0400

What is wrong with the drive being black?
Who the hell cares or wants a stupid looking, flashy drive to stand out in front of everything else?
Who the hell cares if someone else notices your external hard drive?
Most people use an external drive to store or back up data, not to show off in some geeky way?
Are you just collecting hardware to show off for others? Why? You're a real freak.

Wed, 09 May 2012 20:20:40 +0400

for the sake of the article, the HD model WD20EADS that comes inside it is NOT 7200. It is 5400rpm green version.

Mon, 19 Nov 2012 11:50:18 +0300

The card seems to work for all three of my 2.5 laptop SATA drives (Seagate Momentus 7200.3 320GB, Fujitsu 80GB, and Hitachi 160GB from PS3), so I believe it not an issue with firmware or WD trying to block this card from servicing other manufacturers, but an issue of insufficient power. The card was designed with the 3.5" Green line of WD drives in mind which only consume 5W at read/write whereas the 3.5" Black line of WD drives consume 8W at idle and nearly 11W at read/write.

Digital Treesloth
Thu, 29 Nov 2012 02:13:40 +0300

That's a good point, Digital Treesloth. I don't know why I've never thought of that as a possibility.

Chieh Cheng
Thu, 29 Nov 2012 02:59:59 +0300

I bought 3 of those HDD cases from a guy who had used the original WC disks. I put in seagate pipeline HD2 disks, but they wouldn't spin. I used a soldering iron to connect +12 and +5 volt from the 1607 board direct to the sata power connector. In case of the +5 volt you only need a drop of solder to connect it to the coil output (remove solderscreen first). +12 Volt goes direct to adapter input connector. They work fine now!

Fri, 13 Sep 2013 21:39:54 +0400

Thank you
I low leveled format and now every drive works.

Adam Ericson
Tue, 12 Nov 2013 09:12:26 +0300

Thank you so much for sharing the solution!

Writing Zeroes (connected to internal SATA) to the entire disk solved my problem!

I used "Data Lifeguard Diagnostic für Windows" provided by Western Digital ( . . .

After that, the disk is (re-)usable inside the case and partitioning and formating works (tested on Win XP Pro & Ubuntu 12.04)

Sun, 19 Jan 2014 15:04:53 +0300

I have bought a WD Enclosure and a 500GB SATA3 WD drive made in 2013.
It didn't work.

But I had a lot older 500GB SATA2 WD drive made in 2010 and with that drive the enclosure works fine.

I don't know why the older one works fine and the newer one doesn't but at least I'm happy that one of them works just fine.

Thu, 20 Feb 2014 02:53:57 +0300

I bought WD Elements 3TB and replaced with 500G.

I could not partition and format in Windows. I loaded it on Mac but it only appeared as 3TB and could not do anything.
I then loaded it on Ubuntu and used disk utility. Specified 500G to partition although it shows 3TB and it successfully created 500G partition and format. After this, I can use it Mac and Windows.
I tried to partition 501G or 502G then it fails so I guess you will have to find the exact value of the HDD size.

Hope this helps anyone.

Bryan Lee
Wed, 16 Jul 2014 01:14:20 +0400

I am so glad I stumbled into this discussion because I almost gave up hope.
My 2tb drive went into my nas from my Elements and I had an extra 1tb drive sitting around and no pc to use it on (no longer have a desktop). After reading through all this and trying "Data Lifeguard Diagnostic for Windows" using a friends computer it finally worked. I only did the quick erase too (I think it zero'd out the first and last chunk of my drive).
After using the diagnostic tool, I put the usb adapter onto the new drive and had Windows' Computer Manager initialize the drive and format it. This time not "Access Denied"!
Thank you for your help!

Mon, 18 Sep 2017 10:12:15 -0700

Hi. This is the only site that helped me, so I decided to write here about my result
My sister's children dropped the WD Ext HDD 1021 USB Device, after which it stopped working. I bought a new 500GB disk, connected it to my laptop via a USB 3.0 adapter, checked, created partitions and then inserted the USB Device into the WD Ext HDD 1021 instead of the faulty disk, but Windows 10 did not see the partitions. After opening the disk management manager, I received a request to initialize the disk. I confirmed it, but was denied access. Next, I booted into the LiveCD from a USB stick, but no programs there had access to the disk either
Later, I counted the firmware from the flash memory from the Oasis Desktop 1607P board, but I found new firmware only on closed forums, from where I could not download them
I tried connecting other drives to OASIS. Seagate didn't even spin up, but just the LED was blinking. Other WDS of different capacities were also defined without access-denied partitions.
Next, I found this website and a description of my problem. I reconnected my new 500GB WD to a USB 3.0 adapter. We've seen each other. Next, I booted from the LiveCD and launched Low Level Format for full formatting. (I found information here above that it was possible to do quick formatting). Then I moved the WD 500GB to the WD Ext HDD 1021 USB Device and access appeared. I've opened the partition and the disk is working fine.
If you do not have a LiveCD, it might be possible to erase the disk "0" with the help of the Victoria 5.35 program by checking the disk for erasing from DDD. It might help to simply delete all partitions before connecting to the WD Ext HDD 1021 USB Device, but I don't want to experiment anymore. So I lost a lot of time.
Thank you all!

Attached File: oasis desktop 1607p USB TO SATA.bin (128 KB)

Sun, 17 Mar 2024 03:52:38 -0700

<< Back to Article

Add Comment | Related Links | TrackBack
Related Content

Did your message disappear? Read the Forums FAQ.

Add Comment

Spam Control | * indicates required field
Your Name: *
Remember Me!
Comment: *
File attachment is optional. Please do not attach a file to your submission unless it is relevent.
Attach File:
(20 MB Max)
Spam Protection: * Answer of 2 + 1?
Click button only once, please!


TrackBack only accepted from WebSite-X Suite web sites. Do not submit TrackBacks from other sites.

Send Ping | TrackBack URL | Spam Control

No TrackBacks yet. TrackBack can be used to link this thread to your weblog, or link your weblog to this thread. In addition, TrackBack can be used as a form of remote commenting. Rather than posting the comment directly on this thread, you can posts it on your own weblog. Then have your weblog sends a TrackBack ping to the TrackBack URL, so that your post would show up here.

Messages, files, and images copyright by respective owners.

Back to Article

Articles | Wiki
Forums | Latest | RSS
Library | Links | News
Search | Store | Help

154 Users Online

Hacking Digital Cameras
Fun for Photographers

Amazon Associate

Copyright © 2004 - 2024. All Rights Reserved.