Add Comment | Related Links | TrackBack
Related Content

Toshiba Canvio Desktop External Hard Drive Disassembly

I tried using the adapter from the Toshiba Hard drive on another hard drive seagate 2tb and a samsung 500gb and neither showed up on the computer it made the sound that it was connected and it even showed in the device manager that they were connected but it never showed on the computer. Does the hard drive have to be a specific rpm? and another thing the driver for the seagate is not working right but with the toshiba adapter it showed that it was working properly.

Sun, 18 Aug 2013 19:59:19 +0400

My DWC120 2TB died after one weeks usage, the supplier admitted that it was a troubled design with lots of returns.
I had important stuff on it though and so I asked Toshiba if there were any possibility to open it up in an orderly way, save the data, put it together again and return it on that three year guarantee, but as written before, this is a closed for good item. So I used a Japanese handsaw and cut it open just 6-7 mm up from the bottom where the socket ends, and it went very well : nothing save the case walls with their clips and also the devilish clips on the hard drives cradle inside were cut. The bottom came of clean as the hard drive and electronics were attached to the top part of the case. I guess it could be put together again nicely, especially if you sandpaper the top and bottom really smooth and flat, but as my usb interface was fried, I put it in another usb case instead.

Attached Image:


Wed, 02 Oct 2013 03:26:19 +0400

Robert, was the drives spinning? Are they brand new unformatted drives? If they show up in device manager, but not in Windows Explorer, then I suspect they are just not formatted. The final indicator is Disk Management. If they are working, they will show up in Disk Management for you to initialize and format.

Raven, if you do decide to put the case back together, maybe you and device some external fasteners so that you can split the case again in the future.

Wed, 02 Oct 2013 04:18:53 +0400

Hello. I have the same Toshiba Canvio USB3 unit.
I have a problem: if I connect the drive to the PC and then I turn on the PC, the drive partition cannot be see by the OS.
If I unplug / replug it everything works fine.
I use it on a Linux PC server with USB2.0 interface: I have used many external usb drives but I never experienced this problem.
Tried OLD 2.6 / 3.8 / 3.10 kernels, no luck. Is a fault of the interface?
Reading this it seem normal for that HD: . . .
What do you think? Do you have experienced this issue?

Thu, 31 Oct 2013 00:13:47 +0300

Thanks for this info - I recently has a 3TB Canvio fail, and extracted the DT01ABA300 disc (or "Hitachi HDS5C3030BLE630" in the SMART data) which is still working. The USB interface must have failed.

To get at the old backups on it, I directly connected it as a SATA disc on a Linux system, and figured out how to successfully mount it as an NTFS filesystem, and read the data. As the way to do this is a bit subtle, thought it worth recording here.

Connected directly, the drive offers 512 byte sectors to Linux, rather than the remapped 4k sectors via the USB interface. Because of this, the MBR no longer correctly describes the location and size of the NTFS filesystem, so NTFS cannot be mounted in a straightforward way. The MBR says the NTFS filesystem starts at sector 256, and with the USB 4k sectors, that is 1MiB into the disc. However with the directly connected 512 byte sectors Linux understands this to start at 128KiB (256 * 512), so the filesystem makes no sense.

This can be overcome by using the loopback device to directly describe a partition starting at offset 1MiB (1048576 bytes) into the full disc, ignoring the MBR entirely. Here are the commands (on CD bootable Knoppix 7.2 flavour Linux, logged in as root superuser), with the disc showing up as the second disc sdb:

fdisk -l

# check the 3TB disc really is sdb, and the NTFS partition is shown at sector 256

losetup -r -o 1048576 /dev/loop0 /dev/sdb

# Now /dev/loop0 gives the read-only NTFS partition (and beyond if anything were there, but this does not matter)

od -c /dev/loop0 | head

# that shows the start of the partition, and you should see the "NTFS" ascii fingerprint shown
# should "NTFS" not be seen, you could use "od -c /dev/sdb | less" to visually hunt for where the fingerprint is

mount -r -t ntfs /dev/loop0 /mnt

# now the NTFS partition is mounted read-only at /mnt

ls -l /mnt

# DIR of the top directory

I will use this to copy the data to a new disc. I can see no reason why read-write access would not work (leave out -r option on both commands), but I am playing safe and only reading it.

For the record, this is what fdisk -l shows the MBR as:

Disk /dev/sdb: 3000.6 GB, 3000592982016 bytes
255 heads, 63 sectors/track, 364801 cylinders, total 5860533168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xa3f61046

Device Boot Start End Blocks Id System
/dev/sdb1 256 732566271 366283008 7 HPFS/NTFS/exFAT

Luckily I also had saved the fdisk -l output of the drive when it was USB connected earlier as 4k sectors, so for comparison, as /dev/sdc this time:

Disk /dev/sdc: 3000.6 GB, 3000592982016 bytes
255 heads, 63 sectors/track, 45600 cylinders, total 732566646 sectors
Units = sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xa3f61046

Device Boot Start End Blocks Id System
/dev/sdc1 256 732566271 2930264064 7 HPFS/NTFS/exFAT

Hope this is of use to anyone similarly recovering data.

Tue, 26 Aug 2014 15:11:17 +0400

Rwendland, thank you for those instructions. That's exactly what I was looking for.

I'm not needing them yet, since the drive was just bought, but I wanted to make sure that there will be a possibility to salvage the data if the enclosure fails at some point.

Sat, 08 Oct 2016 20:47:35 +0400

<< Back to Article

Add Comment | Related Links | TrackBack
Related Content

Did your message disappear? Read the Forums FAQ.


TrackBack only accepted from WebSite-X Suite web sites. Do not submit TrackBacks from other sites.

Send Ping | TrackBack URL | Spam Control

Title: WD Elements USB HDD
Weblog: GearHack
Excerpt: Couldn't you use Windows Disk Management to re-partition the drive? Like delete its existing partitions and then creating a new partition? It sounds like you took the drive out of the enclosure. In some cases, the USB adapter remaps the sectors. There is a thread talking about it here: Toshiba Ca . . .
Tracked: Wed, 10 May 2017 19:32:29 -0700

Add Comment

Spam Control | * indicates required field
Your Name: *
Remember Me!
Comment: *
File attachment is optional. Please do not attach a file to your submission unless it is relevent.
Attach File:
(20 MB Max)
Spam Protection: * Answer of 8 + 6?
Click button only once, please!

Messages, files, and images copyright by respective owners.

Back to Article

Articles | Wiki
Forums | Latest | RSS
Library | Links | News
Search | Store | Help

146 Users Online

Hacking Digital Cameras
Fun for Photographers

Amazon Associate

Copyright © 2004 - 2024. All Rights Reserved.