: :

Add Comment | Related Links | TrackBack
Related Content

Wayne Dalton idrive Troubleshooting Tip #1 - Check the Fuse

Recently, my garage door became off-balance. Whether it's due to the earth shifting or the old cable drum about to fail is still being debated. But nevertheless, it had caused my Wayne Dalton idrive for Torsion Spring to fail. At one point, it stopped moving altogether. When I pushed the up/down button and the profile button, the garage door opener just chirped and beeped. Calling the customer service resolved the problem quickly. They led me though a number of sequence to deduce the problem. In the end, they asked me to remove the white panel on the right by unscrewing two Philip screws on the bottom. The white panel on the right covers the motor control circuit board (see photo below) and the power circuit.

Attached Image:

Circuit Board Focus on Fuse.jpg

Chieh Cheng
Sat, 03 Jun 2006 12:00:42 -0700

A fuse is on the top left hand corner of the circuit board. It was blown. The customer service explained to me that the fuse it uses is the 250-volt, 4-amp slow-blow fuse (see photo below). It could be purchased at Radio Shack, but they will send me the part for free. To get the idrive going, I drove to the Radio Shack and bought a pack of four fuses.

Attached Image:

Blown Fuse.jpg

Chieh Cheng
Sat, 03 Jun 2006 12:01:09 -0700

A few days later, I received the fuses from Wayne Dalton (see photo below). The box included two fuses and instruction on how to replace the fuse.

Attached Image:


Chieh Cheng
Sat, 03 Jun 2006 12:01:56 -0700

Did the fuse replacement fix your problem?? I also couldnt figure out why my opener quit working but never called the company.I just started to troubleshoot on my own and found the blown fuse.

Randy Lewis
Sat, 10 Jan 2009 20:23:04 +0000

Yes. If it completely stops moving, it's likely that the fuse is blown.

Chieh Cheng
Sat, 10 Jan 2009 22:00:40 +0000

Hey, good writeup. I've had my iDrive for 6+ years now and it stopped today. It was 2 beeps (or beep buzz beep buzz) which is usually fixed by hitting the profile button as I've had to do twice before and is the answer in the not so useful troubleshooting, but this time it just gave 2 beeps then 2 more. I went to Radio Shack as well. The part# is 270-1066 for clarification. :)

Fri, 30 Jan 2009 02:50:21 +0000

Thanks for the help Cheng. I have model 3661. I screwed it up when I was working on the doggie door in my garage door. I pulled the disconnect handle. raised the door by hand half way, set a garbage can under it to hold while I worked. When finished, for some stupid reason I manually raised the door, re-engaged the disconnect, and pressed the button on remote. Needless to say, the motor tried to raise the door - struggled beeped and stopped. Then I finally got things straight, manually lowered the door - but then no response to the button. Nothing - dead, dead. I hoped there was a fuse or circuit breaker on the control board, but have no owner's manual. I read your note about a "FUSE" on your model. So, I removed the circuit board, easy, pops off! saw 2 little round fuses. Tested each. One was bad. So I temporarily put a rigged jumper in the slots. Put board back in. PRESTO!! works great. Got replacement fuse at the shack.
This unit was here when we bought this house 2 years ago. I read a lot of horror stories about W. Dalton units - but mine works fine.

Bob Z
Sun, 17 May 2009 22:40:50 +0000

Glad to have helped.

Don't worry about the horror stories. They are most likely written by deceptive Chamberlain Internet marketers. See "deceptive post" on this thread: iDrive versus Liftmaster 3800

Chieh Cheng
Mon, 18 May 2009 05:53:55 +0000

Thanks so much for the info. For whatever reason my door jammed on the way up. I had to use the release cable to free the door. Then the opener would not opperate. I tried everything I could think of. I went to Wayne Dalton website but could not find the answer. I came to this site and there it was, the fuse..... I went back to Wayne Dalton site and could not find anything about checking the fuse. You guys saved me a service call from the professionals. Thank you again.

Thu, 10 Sep 2009 05:41:05 +0000

I believe I have a problem with the fuse based on what I read here, but when I take off my white cover, the circuit board is not facing me, but is on the top in a horizontal fashion and I can't figure out how to get it out to look for a fuse. Not sure what model I have since the original install slip doesn't say and the manual lists several on the cover. The original unit was installed in 2003 and replaced under warranty a few years ago. It is installed on a 16x7 Wayne Dalton door and I know I have a Torquemaster idrive. Advice? Thanks.

Mr. Ward
Mon, 14 Dec 2009 03:55:42 +0000

I just found something at the Wayne Dalton Web site that explains what I have to do. Can't anything ever be easy?!?

Attached File: Wayne Dalton idrive Fuse Replacement 314883 Rev2 9-29-2004.pdf (234 KB)

Mr. Ward
Mon, 14 Dec 2009 04:12:26 +0000

Well, after I called Wayne Dalton for help with troubleshooting, they told me that my unit does not have a replaceable fuse and sent me a new motor control board (the whole circuit board). I put that in and the unit still didn't work. Another call to Wayne Dalton and they advised me to check my potentiometer gap, which I adjusted, and it still didn't work. I asked if the motor could just be burned out and they said more or less it couldn't be. A third call to Wayne Dalton and the person advised me that my opener was in vacation mode. I explained I already tried turning that off and on and off again, to no avail. Finally, I broke down and called for service from the firm who installed it originally and the tech told me the motor was burned out! I'm getting a new Liftmaster Elite 3850 installed this week. All I will need to pay for is labor - $160. The company who originally installed my iDrive and no longer handles them due to problems they've had with them. I'm pleased they're installing something other than another iDrive and treating it as a warranty replacement.

Mr. Ward
Tue, 29 Dec 2009 05:45:07 +0000

I have 2 torsion I drives that stopped working at the same time. My driveway and myself was hit by lightning on 6-23-10 at 7:30 am. All that happens when I hit the button is a couple of beeps and nothing. The light comes on but no movement on either doors. Customer service said I need a new board. They were on a brand new house not even a year old, no warranty replacement here. They must have sat on the shelf at Menards too long. I am having a hard time finding new ones, if thats what the problem is. Help

Dennis Panozzo
Thu, 02 Sep 2010 02:41:43 +0000

Mine is next I will open it up and check to see if the fuse is open
You know these units are a devil to program or especally erase all the numbers in them from the number units. I have two doors and you can guess what action I get from my fobs 4 when I press a button.

Fri, 24 Sep 2010 00:00:55 +0000

Thanks for this info! I am an electronic tech and didn't even notice the fuse in the dark of the garage where I mounted the unit. I already had the cover off for other reasons years ago and when I shined my flashlight up there the fuse was dark. It would worry me that something else was wrong as that fuse had to blow hard to be dark, but if it worked for you, and others, and your pic shows the fuse dark too, then it'll probably work for me. I'm going to put mine in when I get home from work.

I looked thru the Wayne-Dalton troubleshooting and this was not listed.

Looks like the fuse would be a GDC-4 for those that are looking for the "normal" fuse part number, that other companies use other than Radio Shack. Amazon has them at Littelfuse 4A GDC Type 5 x 20mm Slo-Blo Fuse 5 Pcs.

I would suggest that no one do what Bob Z did and jumper the fuse.

Ryan R.
Tue, 09 Nov 2010 16:41:16 +0000

Well, I followed everybody's advice, got new fuses at Radio Schack, replaced once, nothing, replaced with anotgher new one, and nothing, my unit is still inoperable, beeps and chirps twice, but doesn't move. Any other ideas?

Sat, 26 Feb 2011 23:32:52 +0000

mine is the same. i replaced the fuse and now it beeps twice and then nothing. i got it to do a new profile once, but now only beeps twice.

Wed, 25 May 2011 22:28:13 +0000

Mine doesn't have the fuses. What do I do?

Leon Ramseur
Tue, 05 Jul 2011 20:19:24 +0000

What do you mean by it doesn't have a fuse? Was a fuse missing from the fuse holder? Just put one in then. Is there no fuse holder? Did Wayne Dalton design out the fuse on your board?

Chieh Cheng
Tue, 05 Jul 2011 22:19:54 +0000

I would like to punch Wayne Daltons punk ass square in the nose! I bought a house with one of these p.o.s already installed in the garage due to the low ceiling. I love the house and the garage but this opener has been the biggest pain in the ass. Im a pretty handy guy and have been able to fix this thing almost every time the cable comes off of the roller and clogs up in the gears, which has been multiple times but this time i guess i blew a fuse because it just beeps at me. So im following this link and figure out hoe to replace it but Ole Wayne and his infinent wisdom decided to not only use that crazy little round red fuze but has now soldered it into place in a crazy awkward position. Damn you Wayne!!!!

Sun, 25 Dec 2011 05:09:11 +0300


I'm having similar problems to others here in this thread. My iDrive was working great until just recently the opener only beeps about four times without engaging the drive. No movement. I took my cover off only to find my board is very similar to the original posters picture but without a spot for the fuse. Is there anything else I can do?

Is there any tech support still available for this product?

Please help!


Peter F
Mon, 23 Apr 2012 17:48:25 +0400

The fuse on my circuit board is located at the front right. It is a circular, (can shaped) 5 amp, 250 volt fuse that is soldered to the circuit board. I have two boards, and both have the same type fuse. One is black and the other is dark red.

Mon, 23 Apr 2012 21:35:50 +0400

You can contact Wayne Dalton directly:

Chieh Cheng
Tue, 24 Apr 2012 00:01:35 +0400

I'm starting to see that people are coming here from two different idrive worlds. The original photo showing the fuse holder is for the idrive for Torsion Spring as the original post indicated.

I am guessing that folks with the idrive for TorqueMaster are popping up in this thread wondering where the fuse holder is located at. Based on information presented on this forum, the idrive for TorqueMaster has a round soldered in fuse on the right side of the circuit board. Please confirm...

Chieh Cheng
Tue, 24 Apr 2012 03:26:20 +0400

idrive for Torsion Springs:

idrive for TorqueMaster:

Chieh Cheng
Tue, 24 Apr 2012 03:28:32 +0400

Yes, my idrive is for TorqueMaster. The fuse is circular and soldered to the circuit board on the right side. Sorry if I caused the confusion. Is there another forum for TorqueMaster idrive? I have a motor stuck to the torsion bar.

Tue, 24 Apr 2012 04:10:04 +0400

My drive IS an iDrive for Torsion springs opener, similar to the picture above as well as the original posters picture. It just doesn't have the fuse as his picture shows. I don't find a fuse anywhere else on my iDrive. I could send in a picture if that would help. I don't see that Wayne Dalton supports these anymore. I'm sure mine is a simple fix but just can't figure it out. Any help would be greatly appreciated.

Peter F
Tue, 10 Jul 2012 03:11:05 +0400

See if you can spot the "circular, (can shaped) 5 amp, 250 volt fuse that is soldered to the circuit board" that Jim mentioned. He said it could be either black or dark red. Maybe Wayne Dalton switched to these fuses in newer boards.

The troubleshooting section says "four beeps" mean one of the following . . . so it may not be a fuse problem.

  • Obstruction encountered.
  • Infrared sensor alignment.
  • Out-of-balance condition detected.

Chieh Cheng
Tue, 10 Jul 2012 03:22:09 +0400

Even with the breakdowns of the iDrive that I have had, I still like the unit. I have replaced the circuit board 3 times over the 6 years I have had it but still had not other problems. It recently broke... again. This time I found out the circuit board is warranted for 5 years and mine is now out of warranty.

Wayne Dalton still supports the units provided they are not out of the 5 year MFD warranty. Check the bottom of the unit for the Date of Manufacture. If its less than 5 years, they will probably send you a new circuit board.

I have not checked for a fuse yet as the the opener chirps and I would have thought a fuse would shut the whole unit down, apparently not. Its the first thing I will check when I get home. Who knows, the other 3 boards sitting in my shed may not actually be bad. Unfortunately Wayne Dalton won't sell them to you directly.

Does anyone know a supplier. All the service companies I know tell me that Dalton does not support and try to sell me another brand.

Don S.
Fri, 26 Oct 2012 00:28:26 +0400

OMG. Completely missed the infrared sensor alignment! Door won't operate unless its safe to close after going up. Bad sensor or bad alignment. Where do you find the "Chirp Codes" besides the ones listed above or is that all of them?

Don S.
Fri, 26 Oct 2012 00:42:53 +0400

The codes are in the manual. Search this web site for PDF manuals for the idrive.

Chieh Cheng
Fri, 26 Oct 2012 04:37:47 +0400

I'm going to go home and take another look at the circuit board to see if the fuse has been slodered onto it. I have checked before but will give one last look. Maybe I'll post a picture this weekend. If I do find one soldered, can I just get a new one and re-solder it?

Initially, I noticed that my sensor must have been kicked and wasn't getting the red light alignment verification and thought that was it. I realigned and still no-go. Still getting the "four beeps".

I don't see anywhere that Wayne Dalton still supports these units as Don S. states. Do you have a number to call? I would like to call them. They have been great with any issues over the years and have sent me one replacement unit without question. I want to keep this one working but am stumped.

Peter F
Fri, 26 Oct 2012 19:01:33 +0400

Changed fuse on my I drive like suggested on this thread, then when I hit profile button the door raised about 6 inches and the fuse blew again! Any ideas why the fuse would blow? I disengaged the I-drive and the door moves freely up and down, there doesnt seem to be any friction or resistance.

Chris G
Tue, 29 Jan 2013 05:29:16 +0300

Does anybody know what kind of motor is that? Is it a DC or an AC motor? What is the nominal supply voltage?
My door moved about 10 inches off the floor and stalled. I tried to reset the unit but the door is not moving at all. When the reset button is pressed the door is supposed to go all the way up then down. I measured the voltage supplied to the motor and found 62VDC constant. Also, I measured the winding resistance and got open circuit...
There is no fuse on the board, there is a solid wire soldered across where the fuse holder is supposed to be..
Did anybody have this problem before?

Levi Banta
Sun, 17 Feb 2013 23:32:16 +0300

Fuse was blowing inconsistently, no action except the beeps. Found shorted wires in the motor's power cable. Fixed the wires and have my awesome garage door opener back!

Mon, 06 May 2013 02:48:54 +0400

I just changed the glass fuse, got it at radio shack(250v 4amp slow burn, smaller sized, and the motor started working. It did trip my GFI right after I tried it so I opened the door and closed it a few times and sprayed some good lube on all the wheels and rail and it started working faster. I tried again and then it worked perfect with the opener. I ran it 10 times in a row up and down and they all went perfect. Thank you all for this fix and advice.

Sun, 19 May 2013 05:23:06 +0400

I have another post about my idrive being flaky, but this weekend someone was doing work around my condos and took out some electrical feed to the garages, took 3 days to get power back and now my idrive is dead.
It is an idrive for torsion spring version like the original post, tore it apart, circut board looks like the one pictured, but in the place where the fuse and fuse holder should b its just a resistor. You can see the white printed box on the circuit board where the fuse should go but no fuse. WTF!?

now what do I do?

Wed, 02 Oct 2013 22:45:04 +0400

First check to make sure it's not a tripped circuit in your circuit box. If it does come down to the idrive, I suspect that the fuse in the resistor location is a "fuse resistor". It's still a fuse, just looks like a resistor.

I'm no electrical engineer, so I can't really tell you the difference between a fuse vs. a fuse resistor. But a Google search on the topic will yield some results.

Do you have a picture you can post? Also a picture will be handy to bring to Radio Shack to get a replacement, which I guess, without seeing your board, that you will have to solder in.

Chieh Cheng
Thu, 03 Oct 2013 01:29:29 +0400

I'm a handy guy doing work on my boss' garage door opener. At first it would beep twice and stall. I took the cover off and put it back on and it doesn't do anything. I rechecked it and made sure the ground wires, white/black power wire were all connected. I have the circuit board with the two red can fuses. I'm going to do a continuity check today with my multimeter to see if they're good or not. Thank you for all the help. I will post if this was a success or not to help future people out.

Also I read above the wiring to the motor may be shorted so I will inspect that if the fuses are not blown.

Luke M
Sat, 18 Oct 2014 17:10:17 +0400

There were 2 red can fuses on the circuit board. 1 was good and 1 was bad. Check Radio Shack, Home Depot and local hardware place "that has everything" and they hadn't ever seen anything like it. Guess I need to call a local repair company to buy the part or buy it online.

Luke M
Sat, 18 Oct 2014 23:47:57 +0400

I replaced the old red cap fuses with an inline fuse holder and a 5x20mm 6.3amp 250 volt fuse from Radioshack. It worked great. After replacing the fuse the door would raise a foot then bind. I had to unwind the springs and rewind them making sure the counter balance cable was in the first groove of the winding drum. After that it worked fine.

Luke M
Wed, 05 Nov 2014 14:16:44 +0300

The fuse was the problem!

It did not look burned. However, everything worked ok once I changed it.


Thu, 28 May 2015 03:25:11 +0400

Thanks for this thread. I have 3 of these - 2 work great, but the one most often used just stopped and chirps once. iDrive for torsion and instead of the fuse holder there is just a wire link - the label is still F1, so looks like WD removed the fuse at some point.
I removed the motor assuming it have burnt out, there was open circuit between the connectors, but on opening the motor there appeared to be nothing wrong. Turns out the cable has shorted about half way down its length.
Does anyone know if there is another fuse on the board or a circuit breaker - Can I test the board before i invest too much time repairing the cable / motor?

Rob Clark
Wed, 17 Jun 2015 14:55:07 +0400

I know this conversation is a few years old but I have some more information regarding the 2-beep problem. While 2 beeps does indicate a calibration/install problem, it doesn't necessarily mean you just need to run calibration. My unit started having the problem after after the door got jammed and unbalanced. After getting it fixed the opener wouldn't work. It would beep twice and either move an inch or do nothing at all. I was convinced the motor was not burned so I opened the covers and evaluated all the moving parts. In the end I learned that the plastic threaded shaft under the left cover moves when the torsion bar spins. I noticed my carrier was all the way to the right. It appeared to me that it was trying to travel to the right more but it ran out of space. I loosened the gears rolled the shaft until the mechanism was all the way to the left. Tightened the gears again and ran the install routine. Viola! That did the trick. It was beeping twice because it couldn't calibrate. I attached a picture of the mechanism I am talking about. The black carrier needs to be on the left with the door down. I hope this will help someone else save their Torquedrive. Mine is 13 years old and working great.

Attached Image:


Fri, 31 May 2019 21:54:48 -0700

I had a similar problem with my Idrive for torsion springs - my large 18' x 9' door would raise to 6" and quit- when I would hit the button, I would get 2 beeps and three rapid noises . This started happening, I thought, after the door closed on top of an air hose and apparently jammed it.
I manually cycled the door several time to make sure that the door was balanced and weighted properly.
At all points open or closed I would get the 2 beeps and 3 bullet noises.
I then tried the instal routine and the door would still only raise to approx 6 " and quit. After manually cycling it, I tried the install routine and would manually lift up on the door as it started and I was able to get it passed the 6" point and the the door raised on its own (appeared to raise slower) - went to full open during the install routine then while closing (during the install routine) it stopped at the 6" point off of the ground and would stall the install routine.
I then removed the covers from the idrive unit to check the carrier position as Rob Clark advised above. Noticing that the carrier was all the way to the left, as it should in the down position, I thought that either the motor had to be bad or there was a voltage issue that made the motor not have enough power to lift the door.
After checking the power cable that went to the down stop on the unit- I notice that the cable was pinched and when I desheathed it the black wire was only connected by a few strands of wire. This apparently is an issue as the wire was being pinched on the door open / close cycle.
After splicing the black wire and putting in a strain relief - all works good.
I have had this Idrive for almost 12 years and I love the quiet and no chains. I have a brand new one in a box waiting for the day that this one permanently fails.

My advise to all is if you are having problems - first manually cycle your door to make sure it is in balance and has no friction spots. The door should have a good balance where it doesn't raise or lower on its own.

I would also recommend frequently lubing all rollers with a good garage door lube. - No Squeaks should be present.

As mentioned above, I would recommend checking your carrier position that it is all the way to the left with door closed.

I would then recommend checking the wiring and running your install routine. The door should run up - then down = then up and down again and that will set your open (bottom) and closed (top) stops.

If your idrive won't complete the install routine - you will need to isolate the problem to continue.

I hope this helps.

Mark S
Mon, 28 Oct 2019 18:32:55 -0700

installed 2 idrives in 2004, have blown a fuse or two over the years, otherwise great unit, for me. unfortunately one died today. actually i just get 1 beep, i had been using it earlier today, no problems!, i have yet to pull the board off and inspect. I will get up there though and look for wire damage.
thanks for the tips!


Tue, 01 Nov 2022 20:18:40 -0700

Add Comment | Related Links | TrackBack
Related Content

Did your message disappear? Read the Forums FAQ.

Add Comment

Spam Control | * indicates required field
Your Name: *
Remember Me!
Comment: *
File attachment is optional. Please do not attach a file to your submission unless it is relevent.
Attach File:
(20 MB Max)
Spam Protection: * Answer of 8 + 4?
Click button only once, please!


TrackBack only accepted from WebSite-X Suite web sites. Do not submit TrackBacks from other sites.

Send Ping | TrackBack URL | Spam Control

No TrackBacks yet. TrackBack can be used to link this thread to your weblog, or link your weblog to this thread. In addition, TrackBack can be used as a form of remote commenting. Rather than posting the comment directly on this thread, you can posts it on your own weblog. Then have your weblog sends a TrackBack ping to the TrackBack URL, so that your post would show up here.

Messages, files, and images copyright by respective owners.

Articles | Wiki
Forums | Latest | RSS
Library | Links | News
Search | Store | Help

162 Users Online

Hacking Digital Cameras
Fun for Photographers

Amazon Associate

Copyright © 2004 - 2024. All Rights Reserved.