: :

Add Comment | Related Links | TrackBack
Related Content

Ubuntu 10.04 Netbook Remix on Acer Aspire 3004WLMi

A few months ago, the Acer Aspire 3004WLMi that was running as our Linux server crapped out. Funny thing is that it only crap out when the hard drive is in it. It doesn't matter what hard drive I swap it, during BIOS boot, the computer always shuts off. I'm guessing the power supply can no longer support the power required by the notebook computer. Since then, I've installed Ubuntu 10.04 Netbook Remix on an USB flash drive and have been booting the Acer Aspire 3004WLMi with it. So far, the combination works great; I'm even typing up this post on the laptop. The only thing hat doesn't work is the built-in wireless G WiFi. But I'm going to get it to work and document my adventure here.

For starters, I've read on the Internet that the internal WiFi card is a Broadcom. The following command can help us get more information on which Broadcom chipset it uses.

lspci -vnn | grep 14e4

That command, on our Acer Aspire 3004WLMi, yields the following output.

00:0b.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)

Checking the "b43 and b43legacy" web site, we see that this chipset is supported:

14e4:4318 supported BCM4318 b/g G b43

That's good news. Hopefully, with news like that, I'll be able to make the internal wireless card work without any fuss. For now, let me go read up some more on that web page.

Chieh Cheng
Sat, 25 Sep 2010 20:36:02 +0000

Last night, I screwed up the Ubuntu 10.04 Netbook Remix that was installed on my 2 GB flash drive; I tried to update it and just used up the entire free space. So I wiped it and started over. When I booted off the flash drive, I noticed a little icon on the top right-corner. The icon looked like a PCI card. When I clicked on it, it said, "Install Drivers". I clicked on it, which brought up the "Hardware Drivers" dialog. The dialog showed "Broadcom B43 wireless driver", which was inactive. I clicked on the download and install button and now it's installed. Maybe this task is a lot easier than I thought. I'm going to try it now.

Chieh Cheng
Sun, 26 Sep 2010 19:42:38 +0000

It worked! But it's a little more troublesome than I expected. After rebooting the computer. Several strange things occurred. The wireless is turned off and various things crashed. Firefox wouldn't even start. The operating system went into an endless loop. I turned off the computer and turned it back on again. This second time, I"m a little more careful and not as aggressive at activating the WiFi service.

After Ubuntu 10.04 Netbook Remix completely booted, it reported something about the indicator applet failing and asked whether I want to delete it. I choose no. It crashed again. I just ignored the problem, hoping it has nothing to do with WiFi.

Next, I sat and waited for wireless connection. Nothing happened. The wireless LED in front of the notebook didn't come on. I press the wireless LED button once. After a little while, the LED came on and the computer connected itself to the wireless network in my home. WiFi seems to work. I'm typing up this post using it. The wireless LED blinks on and off.

So far, it seems to work. The fact that wireless starts off when the computer is turned on is disturbing. I hope it'll come on automatically in the future. If not, manual-activation is ok, but it'll just confuse my family members.

Looks like wireless network driver installation is easier than I expected. Not much of an adventure after all. And I was wrong; Ubuntu 10.04 Netbook Remix works completely on the Acer Aspire 3004WLMi. However, you have to use the wired network connection (technically, I don't know if this works, because I didn't use it) to install the wireless driver. Or in my case, I used the Airlink101 AWLC4130 Wireless CardBus Adapter, which works right off the bat on Linux, to get the notebook onto the Internet.

Chieh Cheng
Sun, 26 Sep 2010 20:00:35 +0000

Today, I turned on the computer and booted into Ubuntu 10.04 Netbook Remix, but the wireless network wouldn't work.

I haven't used this computer in a long time and left it in a standby mode. But the power plug was acccidentally unplugged.

It took me a long time to figure how to get wireless networking to work again.

You have to right-click the wireless icon to bring up the pop-up menu. Then "Enable Wireless" from the menu. After during that, push the physical wireless button on the front of the laptop computer. Then you are good to go again.

Chieh Cheng
Mon, 06 Dec 2010 04:34:14 +0000

Add Comment | Related Links | TrackBack
Related Content

Did your message disappear? Read the Forums FAQ.

Add Comment

Spam Control | * indicates required field
Your Name: *
Remember Me!
Comment: *
File attachment is optional. Please do not attach a file to your submission unless it is relevent.
Attach File:
(20 MB Max)
Spam Protection: * Answer of 9 + 2?
Click button only once, please!


TrackBack only accepted from WebSite-X Suite web sites. Do not submit TrackBacks from other sites.

Send Ping | TrackBack URL | Spam Control

No TrackBacks yet. TrackBack can be used to link this thread to your weblog, or link your weblog to this thread. In addition, TrackBack can be used as a form of remote commenting. Rather than posting the comment directly on this thread, you can posts it on your own weblog. Then have your weblog sends a TrackBack ping to the TrackBack URL, so that your post would show up here.

Messages, files, and images copyright by respective owners.

Articles | Wiki
Forums | Latest | RSS
Library | Links | News
Search | Store | Help

225 Users Online

Hacking Digital Cameras
Fun for Photographers

Amazon Associate

Copyright © 2004 - 2024. All Rights Reserved.