: :

Add Comment | Related Links | TrackBack
Related Content

Mount Linux RAID Drive via USB

I'm trying to mount a RAID 1 hdd from my Iomega ix2 NAS to a laptop running Ubuntu. For some reason, the drive is not visible from fdisk -l. It was showing in lsusb and now it is not.

I tried to mount it running mount /dev/sdb2 /media/usbhdd but got an error message: mount special device does not exist.

Can you think of something that would allow me to mount the drive and copy the data off of it?

Would a disk duplicator allow me to back up the data or drive image? How about something like Acronis to capture the image. Again, problem with software is that the OS is not recognizing the hardware. My last resort it to send it to Kroll Ontrack for Data Recovery. That's going to cost $700 to start.


Sp Chess
Thu, 13 Mar 2014 02:08:12 +0300

Is the hard drive removed from the NAS and plugged into the laptop with another USB adapter?

Does the drive show up as /dev/sdb and /dev/sbd2 after you plug it in? Before you plug it in, /dev/sdb doesn't exist, right?

Which Ubuntu version are you using?

What is the drive / partition format? How many partitions?

Thu, 13 Mar 2014 02:27:14 +0300

One of the nas drives (3.5" hdd) is connected to the laptop via a usb adapter. No other devices are attached to the laptop.

Sp Chess
Thu, 13 Mar 2014 21:53:14 +0300

What about the other questions?

Thu, 13 Mar 2014 22:26:20 +0300

It only showed up as /dev/sdb2 once. There is another 20 gb partition for the NAS OS on sdb1. It is no longer showing /dev/sdb when i run lshw.

I installed version 12 of ubuntu.

Sp Chess
Thu, 13 Mar 2014 23:23:23 +0300

Ok. I can only give you some tips, because you didn't answer all my questions.

Before plugging in the drive into the computer, you can look at /dev for all storage devices (using the ls -alF) command. You should see /hd* and /sd*. Make a list of all drives that are attached in this manner.

After plugging in the USB drive, you should look at that list again to see if anything shows up. (We will use "sdb" as an example.)

This is where I need to know the partition and format of the drive, which I don't know. But here is some pointers. The physical drive itself should show up as /dev/sdb. For each partition (that Ubuntu understands), you should /dev/sdb1, /dev/sdb2, /dev/sdb3, etc. If you don't see /dev/sdb, you won't see any partitions, because Ubuntu doesn't even see the physical connection to the drive.

If Ubuntu doesn't see the physical drive, then you need to start debugging Linux USB messages. First unplug the drive from the computer. Output the USB messages. You may even be able to watch it using "tail -f" while performing the next step. Plug the drive in and see what USB message shows up. Give it 30 seconds or so to see all relevant messages.

Fri, 14 Mar 2014 05:27:02 +0300

Ubuntu sees the /dev/sdb for the usb connection. Two data partitions (volume 1 - 20 gb and 2 - 1.8 tb). Data is on 2. Sudo lshw reports that sdb2 iswhere the data is.

Fdisk -l does not shoe sdb2 only sdb and sdb1.

I tried to mount it again and got: unknown file system type 'linux_ raid_member'.

Tried installing the mdadm and got a little further.

Mdadm --assemble --scan --run
/dev/md0 and md1 visible
Mount /dev/md1 /media/usbhdd
Mount : can't read superblock

Stuck at this point. Haven't found anything helpful to continue.

Sp Chess
Wed, 19 Mar 2014 23:20:33 +0300

Right now, the partition format is the important information that's keeping you from moving forward. Do you know what format the partition is in?

If it is a standard format that Ubuntu 12 should know about (ext3, FAT32, etc.), then there may be something wrong.

If it is a standard format that Ubuntu 12 doesn't know about (NTFS, HFS+, etc), then you can find the driver for that format and install it into Ubuntu 12.

But if it is a completely proprietary format, then you are going to have problems. I don't know anything about your NAS... but the best case is to get the drive to work in the NAS that uses that proprietary format and read the data off as soon as possible.

Oh. One more thing. Before and after running mdadm, check fstab and mtab to see if it is already mounted after mdadm ran. If you have auto-mount rules, it may be mounted and ready to use.

Fri, 21 Mar 2014 00:22:41 +0300

Fstab and mtab do not have the entry. When booting with the USB attached, it tries to boot of the USB and hangs. After booting Ubuntu and then connecting the USB, I can see it in cat /proc/mdstat as inactive.

Md1 : inactive sdb2[3](s)
1932533488 blocks super 1.0

Md0 : inactive sdb1[2](s)
20980800 blocks

Fisk -l yields
Disk .dev.sdb: 2000.4 GB

Device. Boot.Start. End. Blocks. Id. System
/dev/sdb1 1. 3907029167. 1953514583+. ee. GPT

/dev/sdb2 does not appear on fdisk.

Ran mdadm --assemble --scan --run and then fdisk again, but still no sdb2. Mounting results in can't read superblocks.

Is there a way to mount GPT or download testdisk to scan the drive?

Sp Chess
Fri, 21 Mar 2014 20:58:29 +0300

Not sure how to answer your question. Are you saying GPT is not readable by Ubuntu? The last time I check, I thought the latest version of Ubuntu needed, or at least supported, GPT for boot. I can't remember if the "latest" version was 12.10 or 13.04.

There are many partitioning software for UNIX. They all operate differently and will give you different results. I remember gparted was my favorite. Definitely try several partitioners.

So after you run mdadm, sdb1 and sdb2 did not show up on the Unity desktop, eh?

And I guess you don't know what its file format is?

Did you try plugging into a Windows machine and see what Disk Management shows?

Sat, 22 Mar 2014 01:54:50 +0300

I'm running testdisk now and it appears that the disk integrity is fine. I'll do a image copy with a duplicator device and work in the copy. I will need to ship the drive back since the sent me a replacement unit.

Sp Chess
Sat, 22 Mar 2014 04:20:33 +0300

Add Comment | Related Links | TrackBack
Related Content

Did your message disappear? Read the Forums FAQ.

Add Comment

Spam Control | * indicates required field
Your Name: *
Remember Me!
Comment: *
File attachment is optional. Please do not attach a file to your submission unless it is relevent.
Attach File:
(20 MB Max)
Spam Protection: * Answer of 3 + 10?
Click button only once, please!


TrackBack only accepted from WebSite-X Suite web sites. Do not submit TrackBacks from other sites.

Send Ping | TrackBack URL | Spam Control

No TrackBacks yet. TrackBack can be used to link this thread to your weblog, or link your weblog to this thread. In addition, TrackBack can be used as a form of remote commenting. Rather than posting the comment directly on this thread, you can posts it on your own weblog. Then have your weblog sends a TrackBack ping to the TrackBack URL, so that your post would show up here.

Messages, files, and images copyright by respective owners.

Articles | Wiki
Forums | Latest | RSS
Library | Links | News
Search | Store | Help

127 Users Online

Hacking Digital Cameras
Fun for Photographers

Amazon Associate

Copyright © 2004 - 2024. All Rights Reserved.